WordPress SyntaxHighlighter Evolved eklentisi

Bloglarında örnek verirken kod yazan arkadaşlar için hemde kullanıcılar için kodları renklendiren bir eklenti yazılmış; SyntaxHighlighter Evolved. Eklenti kullanılan bütün dilleri neredeyse destekliyor, liste için tıklayınız!

Eklentinin kurulması; paketi indirip “zip”ten çıkardıktan sonra blogunuzun bulunduğu klasordeki “wp-content” içindeki “plugins” klasorune kopyalamanız yeterli daha sonra zaten ayarlarını kendiniz yapabilirsiniz.

Kullanırken yazacağınız kod php ise köşeli parantezler içinde php yazarak açıyoruz daha sonra aynı “tag”ı / ile kapatıyoruz, burada eklenti kurulu olduğu için kapatmıyorum.Ayrıca yayınlanan son sürümünde “türkçe” dil desteğide getirildi.Teşekkürler Viper007!

Not: Bazı temalarda uyumsuzluk problemi olduğu düşünürken eklenti sahibine neden kaynaklı olabileceğini sordum. Cevap olarak ;
Temanızın footer.php dosyasında

<?php wp_footer(); ?>

kodunun olup olmadığına dikkat edin eğer yoksa javascript dosyaları yüklenmeyeceği için eklenti çalışmaz. Verdiğimiz kodu footer.php de herhangi bir yere eklerseniz uyumsuzluk problemi giderilmiş olur.

One thought on “WordPress SyntaxHighlighter Evolved eklentisi”

Leave a Reply

Your email address will not be published. Required fields are marked *